Immobilizer problem

Any electrical issues

Immobilizer problem

by rich30mex » Sat Aug 12, 2017 7:35 pm

Got up this morning and went to take the car to pistons in the park but she refused point blank to start. Luckily Mr armstrong had his tech 1 with him and was kind enough to lend it to me. When plugging it in I got 2 error codes the first was mass air flow fault the second was immobilizer code 145. I cleared them both but the immobilizer one went for immobilizer code 145 to immobilizer 144 and the car still will not start. Anyone know what is the best route from here on in is as I'm sh1t with electrics

Thanks
Attachments
20170812_184709.jpg
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by rich30mex » Sat Aug 12, 2017 9:51 pm

Now managed to get all codes removed and nothing showing but still no joy I have given up on it for the night and took the battery off going to see if the "man reboot" (removing the battery blowing on it and reconnecting the battery ) will work
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by Cliff » Sun Aug 13, 2017 8:42 am

Does the engine management light flash when your trying to crank? (I know the engine isn't cranking)

Do you have a second key you can try to rule out the chip in the key being the fault?
User avatar
Gold Club Member
Gold Club Member
 
Posts: 228
Joined: Tue Jan 05, 2016 11:26 pm
Location: Linköping, Sweden

Re: Immobilizer problem

by rich30mex » Sun Aug 13, 2017 10:29 am

No mate it turned over but will not start
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by Cliff » Sun Aug 13, 2017 10:55 am

Sounds like either the collar isn't recognising your key, i.e. Chip fault or the collar isn't sending the right code to the ECU i.e. Collar fault
User avatar
Gold Club Member
Gold Club Member
 
Posts: 228
Joined: Tue Jan 05, 2016 11:26 pm
Location: Linköping, Sweden

Re: Immobilizer problem

by rich30mex » Mon Aug 14, 2017 2:00 pm

right lets up date this

batterys been off for 38 hours cleared all codes on the ecu but still no joy. I can not hear the pump priming and theres no fuel at the fuel rail
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by Cliff » Mon Aug 14, 2017 2:11 pm

It's the immobiliser IMO - did you try with a spare key chip to rule that out?
User avatar
Gold Club Member
Gold Club Member
 
Posts: 228
Joined: Tue Jan 05, 2016 11:26 pm
Location: Linköping, Sweden

Re: Immobilizer problem

by rich30mex » Mon Aug 14, 2017 4:11 pm

Yes I did mate still nothing I'm waiting on a non immobilized ecu to try that see if that solves it if it does I have been told to get a set of chips from Courtney or some where like that as it remove the immobilizer from my ecu
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by Cliff » Mon Aug 14, 2017 4:18 pm

Could be the collar at fault or even the ECU - let me/us know how you get on with the replacement
User avatar
Gold Club Member
Gold Club Member
 
Posts: 228
Joined: Tue Jan 05, 2016 11:26 pm
Location: Linköping, Sweden

Re: Immobilizer problem

by rich30mex » Mon Aug 14, 2017 6:10 pm

No joy with the none immobilizer ecu trying a new crank sensor tomorrow
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by Allys Cally » Mon Aug 14, 2017 8:56 pm

your saying your not getting any fuel but are you getting spark?
BETTER TO HAVE A CALIBRA AND NOT NEED ONE, THAN NEED A CALIBRA AND NOT HAVE ONE!!!

BEST STANDARD BILLING 2009 CO-OWNER
BEST STANDARD BILLING 2011 CO-OWNER
BEST PRESENTED BILLING 2012
BEST ENGINE BAY BILLING 2015
Chairmans Choice - Scottish Car Show 2016
BEST INTERIOR VBOA 2017
User avatar
Club Member
Club Member
 
Posts: 3237
Joined: Tue May 15, 2007 7:30 pm
Location: east ayrshire, scotland

Re: Immobilizer problem

by rich30mex » Tue Aug 15, 2017 9:40 am

Tbh not even looked for spark
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by cal16v » Wed Aug 16, 2017 12:50 am

Sorry to hear of your woes rich...

Was the alarm triggered prior to the no start issues? I'm not 100% but I would suspect the alarm is on a separate circuit to the immobiliser and would take precedence. Simple lock/unlock should satisfy if so.
Another thing to maybe check are the contacts at the diagnostic plug itself... dirty connections, wet etc.

Good luck
User avatar
Club Member
Club Member
 
Posts: 183
Joined: Tue Apr 15, 2014 11:19 am
Location: Sydney Aus

Re: Immobilizer problem

by rich30mex » Wed Aug 16, 2017 7:52 am

No mate there was no alarm and already tried the door lock and in lock I'm waiting on a crank sensor to see what happens then bud
Calibra l,e number 4
Project it's a secret
Best engine bay 2011
Best engine bay 2014
Best in show 2016
Treasures cup 2016
best engine bay 2017


Have car have cloth will clean need life
User avatar
Gold Club Member
Gold Club Member
 
Posts: 2897
Joined: Sat Jan 03, 2009 11:19 am
Location: a hovel

Re: Immobilizer problem

by cal16v » Wed Aug 16, 2017 7:55 am

Just another thought... trigger the alarm and then try the key trick again. Nothing to lose
User avatar
Club Member
Club Member
 
Posts: 183
Joined: Tue Apr 15, 2014 11:19 am
Location: Sydney Aus


Who is online
Users browsing this forum: No registered users and 3 guests