Ooops !!! - I don't think this is right ?? - Bilstein

Any issues relating to suspension, steering and brakes.

Ooops !!! - I don't think this is right ?? - Bilstein

by martinb » Fri Oct 30, 2009 11:39 am

Back in the summer of '07 I bought this kit for the V6 from Demon Tweeks as they had it on special offer.

Image

Image


I didn't get round to fitting it until last Aug '08, I had to fit the rear springs and shocks due to an MoT failure (broken spring)
I have done less than 5k miles since fitting the rear springs/shocks, this years MoT I was advised by the tester that one shock was 'misting' oil !!
The springs don't look right to me either ?? See pics below.......... Pics taken with the car empty & on level ground.

Image

Image

I would like to contact Bilstein to get their opinion, as you can appreciate I don't want to fit the front springs & shocks if there is something wrong with this kit
I would welcome your comments
martinb
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by BIG DAN » Fri Oct 30, 2009 12:01 pm

wow !! was they like that when you fitted them, have you noticed the car drop since fitting them, are both sides like that ???
i would jack the car up and see if the spring spreads and then remove the shock and push that down and see if that is coming back out properly
deffentutly take back to where you bought them from and ask advice they may not be able to refund you or replace but it has too be worth askin you never know you might get them on a really good day lol
BIG DAN
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by martinb » Fri Oct 30, 2009 2:04 pm

The spring coils were quite close to each other whem I first fitted them; both sides are the same.
This is a -35mm kit for the V6.
I have checked on the Bilstein website, the part no's for the shocks are recognised as being for the V6, the no's on the springs do not appear on their listing ??
Springs are marked - OPE3121
Front shocks are marked - PNE-3052
Rear shocks are marked - BNE-1975

I have tried the springs both ways; but it has the same effect !!
The springs should support the weight of the car without the shocks fitted, but these don't !!
As you can appreciate the rear of the car is solid now with no suspension travel !!; strangely the passenger side shock is the one that is 'misting' oil ?? - I do not carry passengers 'nor have I had anything heavy in the car.

I have sent Bilstein an e-mail via their website explaining the problem, so I will see if they respond.
I have used their products many times over the years; starting with my Firenza's & Magnum's, even had them fitted to a couple of my Manta's & never had any problems; hence why I chose them for my Calibra.
martinb
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by Phantom » Fri Oct 30, 2009 2:35 pm

they are definately wrong Martin, here's a pic of mine on a -40mm drop

Image
Phantom
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by Fraz » Fri Oct 30, 2009 2:43 pm

The shocks are correct, but them springs dont look right ..coils are way to close togather ...I suspect you have a 60mm lowering kit

Bilstein dont actually make springs thus you wont find them listed on the website it will be springs from some other supplier. What is the part number of the actual kit?
User avatar
ClubCalibra.net
ClubCalibra.net
 
Posts: 3621
Joined: Sat Dec 06, 2003 1:00 pm
Location: Rosyth Scotland

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by buffkane » Fri Oct 30, 2009 5:18 pm

those springs look very similar to a suspension set i used earlyer this year, for all of about 6 weeks.
the writing on the springs look identical to the Gmax springs i had, also having the same compact spring coils which is the issue you have, was a susposed 40mm drop. when full kit was fitted more like a 60 mm drop.

could be wrong, but the set i had came off set em back. got a refund
buffkane
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by martinb » Tue Nov 03, 2009 4:13 pm

I have checked the part no's on the springs; these are made by Ventura Spring Company - these are -35mm springs for the V6 !!
I cannot find any contact info for this company.

Anyway I have decided to try another set of springs - This morning these turned up......

Image

Image

Jamex -40mm springs, price ? - £76 delivered within 24hrs !!!

I assume that the correct orientation for fitting these springs is the part no's are 'readable' ?? - can anyone confirm this ?

As soon as it stops raining I will get these fitted & report back.
martinb
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by Phantom » Tue Nov 03, 2009 4:37 pm

I would suggest fitting would be the way they are in the photo, they still have the same amount of coils as the other ones? :think:
Phantom
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by Fraz » Tue Nov 03, 2009 5:20 pm

I was always taught that springs (unless otherwise marked) are fitted so the writing is the correct way up
User avatar
ClubCalibra.net
ClubCalibra.net
 
Posts: 3621
Joined: Sat Dec 06, 2003 1:00 pm
Location: Rosyth Scotland

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by marko » Tue Nov 03, 2009 6:17 pm

mine have done the same.almost completely compressed.
marko
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by Phantom » Tue Nov 03, 2009 6:19 pm

they can't be right then either
Phantom
 

Re: Ooops !!! - I don't think this is right ?? - Bilstein

by martinb » Wed Nov 04, 2009 6:43 pm


It was dry today !! so the rear springs have been changed !!!

This is the old spring against the new one.......

Image

Here is the new spring fitted...............

Image

What a difference; the ride height is virtually the same, the car feels so much different to drive.
At least now I have got some compression at the back.
I stood on one of the old springs & was able to nearly compress it fully !!! Tried it with the new one & it hardly moved. So I think the old springs have gone 'soft'.
martinb
 


Who is online
Users browsing this forum: No registered users and 1 guest
cron